So what did you do to your 928 Today...... - Rennlist - Porsche Discussion Forums



928 Forum
Sponsored by: 928 Specialists

So what did you do to your 928 Today......

Reply
 
Thread Tools Search this Thread
Old 02-05-2011, 06:46 PM   #1
Skrilla01
User
Thread Starter
 
Join Date: Jan 2011
Location: Central Jersey
Posts: 129
Default So what did you do to your 928 Today......

I guess I'll go first.
Attached Images
 
Skrilla01 is offline   Reply With Quote
Old 02-05-2011, 07:09 PM   #2
jpNcos
User
 
jpNcos's Avatar
 
Join Date: Mar 2008
Location: At the foot of Pikes Peak
Posts: 928
Default

Looked at it when I went to the garage to grab a dustpan.

It is 25 degrees and snowing though...
jpNcos is offline   Reply With Quote
Old 02-05-2011, 07:13 PM   #3
G Man
Super User
 
G Man's Avatar
 
Join Date: Aug 2002
Posts: 2,615
Default

Nothing
G Man is offline   Reply With Quote
Old 02-05-2011, 07:15 PM   #4
mickster
Super User
 
Join Date: Jan 2010
Location: Greensboro, NC
Posts: 3,718
Default

Just had AAA come give it a jump. Battery Maintainer ain't maintaining (Black & Decker is going bye bye).

Sitting outside (in 40 degree mist) idling for next 45 minutes.

Alternator was giving back 14.5 V. Now to rip out that f'in Alpine amp the PO threw in there directly connected to the battery.

FPO normally is a term used in printing/marketing meaning "For Placement Only."

I think here it should mean:
F'in Prior Owner

Michael

(On a good note this cool air is making for some sweet rumbling idle right outside my window from where I am typing...and the car sounds near perfect).

Last edited by mickster; 02-05-2011 at 07:16 PM. Reason: added a note
mickster is offline   Reply With Quote
Old 02-05-2011, 07:18 PM   #5
Ducman82
Quacker McBoobs
Rennlist Member
 
Ducman82's Avatar
 
Join Date: Nov 2009
Location: Rancho Palos Verdes, CA
Posts: 6,625
Default

i have an autometer battery tender... works wonders.
Ducman82 is offline   Reply With Quote
Old 02-05-2011, 07:19 PM   #6
pcar928fan
Super User
 
pcar928fan's Avatar
 
Join Date: Apr 2008
Location: Austin, TX
Posts: 9,332
Default

I polished EURO85, vacuumed it out and put the nice black lock surround cover lays from Nicole at Hooked on Cars on it too! Took it to lunch with Jim Willman and we had a great drive! Couple of runs well over 100...nice! Car is VERY stable and seems to be getting better the more I drive it! Filled it up with gas too...got 14 mpg on this first full tank I have run through the car. That is about what I get in my GTS's too... I don't baby them! On the open road I do much better!

Michael, I agree with your FPO comment!
pcar928fan is offline   Reply With Quote
Old 02-05-2011, 07:25 PM   #7
tmpusfugit
User
 
tmpusfugit's Avatar
 
Join Date: Apr 2010
Location: Magnolia TX, just north of Houston, Red 1984 S
Posts: 653
Default

Well, it went from 17 degrees last night to a very sunny cloud free 60 degrees today, so I took the 928 for a 25 mile jaunt...I still have a drip drip from the transmission, looks like it might be the hose connection on the transmission to the radiator...have new aluminum rings on order from Roger...assuming he is not snowed in still I should see them soon...and prove or disprove the drip drip issue. And oh, think I will take the 928 up the road tonight to Jacks World Famous Fajitas and indulge a bit, maybe have a margarita or 2..

Weather is saying 70 degrees tomorrow.....
tmpusfugit is offline   Reply With Quote
Old 02-05-2011, 07:55 PM   #8
deptotpr
User
 
deptotpr's Avatar
 
Join Date: Jan 2010
Location: Tampa Bay, Florida
Posts: 276
Default

..drove my son to work at Publix, and filled her up with ga$.

Last edited by deptotpr; 02-05-2011 at 07:56 PM. Reason: sp
deptotpr is offline   Reply With Quote
Old 02-05-2011, 07:58 PM   #9
blandis
User
 
blandis's Avatar
 
Join Date: Jan 2008
Location: Coppell TX
Posts: 441
Default

Started it for the first time in a week. backed it out and swept under it. Oh...checked the fluids before I fired it up.
blandis is offline   Reply With Quote
Old 02-05-2011, 08:00 PM   #10
SeanR
Running up the Odo'
Rennlist Member
 
SeanR's Avatar
 
Join Date: Apr 2006
Location: DFW Texas
Posts: 31,341
Default

Moved mine from the driveway to the street so it could thaw. Then moved it back in to the driveway.
SeanR is offline   Reply With Quote
Old 02-05-2011, 08:06 PM   #11
mickster
Super User
 
Join Date: Jan 2010
Location: Greensboro, NC
Posts: 3,718
Default

Well turns out it was just that the battery was dead. 45 Minutes idling and it starts up no issue (no message on the dash--89 digital Type 04). The maintainer is working just fine now. I will hard wire the maintainer connector to the battery instead of alligators when I disconnect the f'in Alpine amp.

Gawd did it idle perfect and sound sweet...
mickster is offline   Reply With Quote
Old 02-05-2011, 08:27 PM   #12
Tony
No wide loads, please!
Lifetime Rennlist
Member
 
Tony's Avatar
 
Join Date: May 2001
Location: Las Vegas
Posts: 12,634
Default

Up on jacks stands. Installed "stock cats"...and airpump belt. Just need to find my diverter valve/check valve. ...i think i tossed this part out ages ago. Beautiful day out though!

Discovered that i may have a leaking front main seal now...figures. I only had the motor out 5k miles ago...i didnt mess with it as it was dry as popcorn fart! Oh well...live and learn
Tony is offline   Reply With Quote
Old 02-05-2011, 08:30 PM   #13
vtc4198
Addict
Rennlist Member
 
vtc4198's Avatar
 
Join Date: Mar 2007
Location: In traffic
Posts: 837
Default

Parked it and plugged it in
vtc4198 is offline   Reply With Quote
Old 02-05-2011, 08:31 PM   #14
Tony
No wide loads, please!
Lifetime Rennlist
Member
 
Tony's Avatar
 
Join Date: May 2001
Location: Las Vegas
Posts: 12,634
Default

Quote:
Originally Posted by vtc4198 View Post
Parked it and plugged it in
^^^^ nice car. Its has the perfect "stance"..ride height and wheels
Tony is offline   Reply With Quote
Old 02-05-2011, 08:38 PM   #15
dr bob
Chronic Tool Dropper
Lifetime Rennlist
Member
 
dr bob's Avatar
 
Join Date: Oct 2001
Location: Bend, Oregon
Posts: 15,617
Default

Installed new 928RUs delrin rack bushings last evening, and this mornniig drove over to a semi-local hot-rods parking lot gathering to look at some WIP cars that owners think are 'finished'. Dropped by the local parts place on the way back to get a few liters of brake fluid, in anticipation of the annual brake fluid flush session due this spring. Swapped in new coolant last evening while the car was up on the lift for the rack bushings. Or maybe that's the other way around. Bottom line is that the car is driving great, everything works as it should, and by mid-week all the fluids and filters will be refreshed for another diriving season. Still on the list: ATF and filter for Monday.

--------

I should break100k on the car sometime in the next month or two. Gotta get ready for the party that goes with passing the century mark I guess. Before that it will get a little cleaning and polish so it looks a little more like new.
dr bob is offline   Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Heck, I even do this on track... Veloce Raptor Racing & Drivers Education Forum 31 12-29-2016 09:55 PM
I'm blue! PeteyDaddy GT4 43 12-18-2016 01:22 AM
Too many- Gofishracing GT4 8 12-28-2015 02:02 PM
Is this Speed Ref sensor bad? mytrplseven 924/931/944/951/968 Forum 7 10-26-2015 11:34 AM


Tags
1980928, autolack, blackfive, fly, light, lsdpics, marker, msds, navy, plentyoffish, porsche, rear, side, skrilla01, spray

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -3. The time now is 05:43 PM.


Copyright ę 1998 - 2017 Rennlist.com
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: