Starts without MAF barely idles - Page 2 - Rennlist - Porsche Discussion Forums

Notices

Starts without MAF barely idles

Reply

Old 01-08-2018, 05:30 PM
  #16  
Gofishracing
Addict
Rennlist Member
 
Gofishracing's Avatar
 
Join Date: Feb 2003
Location: New Jersey
Posts: 3,437
Default

Gofishracing is offline  
Reply With Quote
Old 01-21-2018, 05:34 PM
  #17  
kgorman
Super User
Thread Starter
 
kgorman's Avatar
 
Join Date: Sep 2005
Location: Austin, TX
Posts: 2,406
Default

I ended up noticing the electrical on the old pump was cracked and falling apart. I decided on a new pump (996-620-133-00) from Sunset. Finally found time to install it and got it all back together and no go! just cranks forever.

So I jumper the fuel pump relay and put a hose on the output of the pump into a fuel jug. No gas!

So I start taking the pump out again figuring I did something stupid when I notice the connector on the level sensor for the output side inside the tank doesn't fit with a good seal. Then I realize the old connectors are one unit, the new connectors are single - the old way was to key them by locking them together, this new pump has different fittings!

So so I can order a new fuel level sender but I have no way of knowing if it has the new style connectors. I could also cut off the old connectors and reuse them, I do have the proper brand/style of hose clamps to duplicate the clamps. I was going to keep my old fuel pump as a spare just in case the cups crapped out, so I don't really want to cut off the connectors if I don't have to.

I think I need part 996-620-801-90 for the new sender. I just don't know if the connectors match my new pump.

hrm....

kgorman is offline  
Reply With Quote
Old 01-21-2018, 05:56 PM
  #18  
kgorman
Super User
Thread Starter
 
kgorman's Avatar
 
Join Date: Sep 2005
Location: Austin, TX
Posts: 2,406
Default

I may have spoke too soon.. it appears that pump is a turbo/c4s part number! Not sure if they sent me the wrong one or I goofed. It appears then I need to get a new pump or change out the connectors.

Unless there is a reason I shouldn't use a c4s/turbo pump, they otherwise look the exact same
kgorman is offline  
Reply With Quote
Old 01-23-2018, 12:13 PM
  #19  
serickson
Addict
Rennlist Member
 
serickson's Avatar
 
Join Date: May 2009
Location: IL
Posts: 247
Default

Just ordered a new pump from Sunset Porsche. I was told correct part number is 996-620-103-90. I originally had wrong number they corrected it based on the VIN. 3-4 weeks from Germany.
serickson is offline  
Reply With Quote
Old 02-22-2018, 10:38 PM
  #20  
kgorman
Super User
Thread Starter
 
kgorman's Avatar
 
Join Date: Sep 2005
Location: Austin, TX
Posts: 2,406
Default

I just wanted to post an update. It took a while for the new pump to show up from Germany, then I found some time to put it in. She's all up and running and man she is sweet. Took her for a quick run before the rain.

I think I will take the c4 pump and the old pump and mix them to create a good franken pump for the cup as a spare.
kgorman is offline  
Reply With Quote
Old 02-24-2018, 12:27 PM
  #21  
Kistle
User
 
Kistle's Avatar
 
Join Date: Dec 2007
Posts: 87
Default

Thanks for the update. Good info. Any pics of the different connectors on the two pumps, and how you might franken them together?
Kistle is offline  
Reply With Quote

Thread Tools
Search this Thread
Quick Reply: Starts without MAF barely idles


Contact Us Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: