Notices

Deltagate sucks again!

 
Old 06-24-2002, 11:07 AM
  #1  
Konstantin
Addict
Lifetime Rennlist
Member
Thread Starter
 
Join Date: Jul 2001
Location: Germany/Braunschweig
Posts: 1,937
Post Deltagate sucks again!

Well after changed my use one with a brand new one and found that the hoses were leaking etc. I THOUGHT I
solved my problems and I finally have a good wastegate.
Well My brand new Deltagate seems not to last full boost runs!
After 2 hours high speed driving at about 130 mph and some full boost runs I decided to drive a little slowly.
After 10 min wanted to go full boost again and found out that the wastegate is stacked close AGAIN.
I found out that the wastage do NOT open even if I apply boost to the boost port. I must one drive again about 200
km till it gets hot again and then after many runs at full boost it "may" will be able to open again.

I had this Problem once last week and now the same.
Anyone has the same Problem with the deltagate or another wastegate?

I know this problem from the older 930 Turbo. You had to go to full boost mane times till the wastegate opens
again but never heard of this on a 951.
I think this happens due to no cool fins on the deltagate.

Also I noticed that the Deltagate can not hold vacuum as the stock wastegate. If you apply pressure to the
wastegate the valve should open and then stay there. The valve on the Deltagate slowly closes and loose the
vacuum. This is not the case with the stock part.
The valve in the DG do not close perfect and do not seat perfect in the valve seat.

Konstantin
Konstantin is offline  
Old 06-26-2002, 06:36 PM
  #2  
hybrid_944
User
 
Join Date: Dec 2001
Posts: 123
Post

I am having waste gate problems also. and i have to say that . Im looking at the Tail 46mm. from speed force racing.. has any one herd good , or bad from this waste gate.


also. on the wastgate problem.

what other mods do you have.. cause did you think about confliction of mods, on each other? <img src="graemlins/crying.gif" border="0" alt="[crying]" />
hybrid_944 is offline  
Old 06-27-2002, 10:06 AM
  #3  
Konstantin
Addict
Lifetime Rennlist
Member
Thread Starter
 
Join Date: Jul 2001
Location: Germany/Braunschweig
Posts: 1,937
Post

I heard the best word for teh tial 46 mm.
My problem is on the wastegate. I checked everything and replaced the wastegate so often that I know every single hose and conection to it.
The valve stucks closed after full boosts and then imediately cooling doown
i don't know why but the valve do not open. If I drive for another 1-2 hors when it will hot again it will be able to open again.

Konstantin
Konstantin is offline  

Thread Tools
Search this Thread

Contact Us - About Us - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: