Hall of Shame - Page 3 - Rennlist - Porsche Discussion Forums

Notices
928 Forum
Sponsored by:
Sponsored by: 928 Specialists

Hall of Shame

 
Old 12-06-2018, 09:59 AM
  #31  
drooman
Addict
Rennlist Member
Thread Starter
 
drooman's Avatar
 
Join Date: Jun 2011
Location: CT and FL
Posts: 999
Default

A rare double blunder photo... some lumpy cat welding, and the "fast fix" front shift cup repair.
drooman is offline  
Old 12-13-2018, 05:22 PM
  #32  
olmann
Addict
Rennlist Member
 
olmann's Avatar
 
Join Date: Oct 2010
Location: Oklahoma City
Posts: 559
Default

So previous owner said that the fan wasnít working. Hmm, I canít see why? 😂



olmann is offline  
Old 12-13-2018, 08:46 PM
  #33  
Jadz928
Addict
Rennlist Member
 
Jadz928's Avatar
 
Join Date: May 2003
Location: Frankenmuth, Michigan
Posts: 8,419
Default

Originally Posted by drooman View Post

That current replacement hanger will look like those bungies in about two week under weight. Virtually worthless. I replace with good condition originals, with the metal internal reinforcement.
Jadz928 is offline  
Old 12-13-2018, 10:45 PM
  #34  
Crumpler
Addict
Rennlist Member
 
Crumpler's Avatar
 
Join Date: Dec 2013
Location: St. Louis
Posts: 1,445
Default

Originally Posted by olmann View Post
So previous owner said that the fan wasnít working. Hmm, I canít see why? 😂



Woof.
Sometimes I tune in just to feel better about myself.
Crumpler is offline  
Old 12-14-2018, 05:18 PM
  #35  
giddyupp
Addict
Rennlist Member
 
giddyupp's Avatar
 
Join Date: Jul 2010
Location: SF Bay Area
Posts: 323
Default

Originally Posted by olmann View Post
So previous owner said that the fan wasnít working. Hmm, I canít see why? 😂



How does that even happen !!!!!! How do you install that and think all is good ?
giddyupp is offline  
Old 12-14-2018, 06:48 PM
  #36  
Gage
Addict
Rennlist Member
 
Join Date: Aug 2012
Posts: 104
Default

And I wonder how many trips to the parts store to get a belt that was the "right" length��
Gage is offline  
Old 12-14-2018, 06:54 PM
  #37  
worf928
Addict
Rennlist Member
 
worf928's Avatar
 
Join Date: Oct 2003
Location: New England
Posts: 11,673
Default

Originally Posted by giddyupp View Post
How does that even happen !!!!!! How do you install that and think all is good ?
The really scary question is: did the same Ďtechnicianí do anything on that (or any other) 928 that was more-involved than installing a belt?
worf928 is offline  
Old 12-14-2018, 06:54 PM
  #38  
monkez
Addict
Rennlist Member
 
monkez's Avatar
 
Join Date: Sep 2016
Location: Southern California
Posts: 111
Default

Originally Posted by olmann View Post
So previous owner said that the fan wasnít working. Hmm, I canít see why? 😂



It appears the car is a hot item....
monkez is offline  
Old 12-14-2018, 11:57 PM
  #39  
olmann
Addict
Rennlist Member
 
olmann's Avatar
 
Join Date: Oct 2010
Location: Oklahoma City
Posts: 559
Default

Originally Posted by giddyupp View Post
How does that even happen !!!!!! How do you install that and think all is good ?
When I first saw it I did a double take, stared for a second with the standard WTF, and then laughed out loud! What is really awesome is there is a second exact same belt in the glove box for backup!

The car is getting a complete tear down. Who knows what else I may find.
olmann is offline  
Old 12-15-2018, 05:23 PM
  #40  
Kevin in Atlanta
Addict
Rennlist Member
 
Join Date: May 2002
Location: Roswell, GA
Posts: 4,913
Default

So, instead of just an air pump delete you got a cooling fan delete as a part of the package. Cool.
Kevin in Atlanta is offline  
Old 12-15-2018, 07:25 PM
  #41  
drooman
Addict
Rennlist Member
Thread Starter
 
drooman's Avatar
 
Join Date: Jun 2011
Location: CT and FL
Posts: 999
Default

What's all this talk about all these cars needing head gaskets?

drooman is offline  
Old 12-16-2018, 11:06 PM
  #42  
RT_955TT_KY
User
 
RT_955TT_KY's Avatar
 
Join Date: Mar 2015
Location: Lexington, KY
Posts: 131
Default


one of many "hidden" gems I've found since starting on my 81 . Every cluster wire had been cut, and the PO must have only had RED wire to splice into the harness and connect to the cluster with BLUE RTV. The labeling is mine as I sort this mess out.


RT_955TT_KY is offline  
Old 12-17-2018, 06:05 AM
  #43  
worf928
Addict
Rennlist Member
 
worf928's Avatar
 
Join Date: Oct 2003
Location: New England
Posts: 11,673
Default

Originally Posted by RT_955TT_KY View Post
... and the PO must have only had RED wire to splice into the harness and
Standard French wiring methodology. Did this one come from Canada?

connect to the cluster with BLUE RTV. The labeling is mine as I sort this mess out.
I think you just won this contest.

worf928 is offline  
Old 12-17-2018, 11:51 AM
  #44  
jeff spahn
Addict
Rennlist Member
 
jeff spahn's Avatar
 
Join Date: Nov 2009
Location: Dubuque, IA
Posts: 7,405
Default

Originally Posted by olmann View Post
So previous owner said that the fan wasnít working. Hmm, I canít see why? 😂



I fail to see a problem here. That fan would turn just fine.....at speed....with a failed viscous drive.....until it didn't.
jeff spahn is offline  
Old 12-17-2018, 11:54 AM
  #45  
jeff spahn
Addict
Rennlist Member
 
jeff spahn's Avatar
 
Join Date: Nov 2009
Location: Dubuque, IA
Posts: 7,405
Default

Originally Posted by drooman View Post
1. Wreck red car 2. Cut up white car 3. connect with hot metal.

I bet the extra drain holes help with corrosion prevention
jeff spahn is offline  

Thread Tools
Search this Thread

Contact Us About Us Advertising Cookie Policy Privacy Statement Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: