Rennlist - Porsche Discussion Forums - View Profile: mdkelly1

Notices

mdkelly1 mdkelly1 is offline

Addict
Rennlist Member

Visitor Messages

Showing Visitor Messages 1 to 2 of 2
  1. mdkelly1
    07-13-2014 01:34 PM
    Hi Don,

    The car would run fine until I fully (or almost fully in some cases) depressed the accelerator. Then it would "bog down" similar to what you might expect with a severe miss under load. Thought it might be plugs or a coil at first, but also knew that it could be fuel related. Even thought it could be a clogged fuel filter since I normally stored my car for about eight months each year. Checked the plugs (looked okay, but changed them anyway). That didn't help. Changed the fuel filter and that didn't help either.

    Decided to have the injectors cleaned.

    Here is the result:
    https://picasaweb.google.com/lh/phot...eat=directlink

    No problem with them since and the car continues to run great. Might not be the source of your problem, but it was definitely the source of mine.

    Good luck with everything. Hope that fixes it.
  2. agent66
    07-12-2014 07:18 PM
    Hi I found a post you replied to ages ago about you had bogging on your 928 and it turned out to be your injectors. My 928 for the most part will run fine for a bit then just bog down when I give it gas then it will sometimes magically smooth out for a bit then all over again with the bog. Does this sound like what you were seeing with your 928? BTW my 928 has been sitting with old gas for quite a bit.

    thanks
    Don

Statistics

Total Posts
Visitor Messages
General Information
  • Last Activity: 02-27-2019 08:30 PM
  • Join Date: 03-01-2007

Contact Us About Us Advertising Cookie Policy Privacy Statement Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.