ABS PSM light only when cold - Rennlist - Porsche Discussion Forums

Notices
996 Forum
Sponsored by: LN Engineering
Sponsored by: LN Engineering

ABS PSM light only when cold

Reply

Old 05-19-2017, 12:29 AM
  #1
eddy_911
User
Thread Starter
 
Join Date: Apr 2017
Posts: 27
Default ABS PSM light only when cold

Hi All,

I have read many ABS PSM lights thread and the consensus is that it could be caused by either MAF, Wheel Sensor, Air Filter being dirty, brake switch. I have a sort of different situation.

I noticed that the ABS and PSM lights only come on during cold temperature (say 45 F or below) and it doesnt come on when warm even driver after 40 minutes or so.

I changed the air filter tonight and noticed that the airbox was full of dirt.

I went for a drive afterward and the lights did not come on (temp is above 85F).

Also, i know that my brake lights are working so I am ruling out the brake switch issue.

The only thing left is the MAF and wheel sensors. Since the lights are coming on when cold, do you guys agree that the MAF is more likely to be the issue than wheel sensors?

Thanks for reading.
eddy_911 is offline  
Reply With Quote
Old 01-13-2018, 12:33 PM
  #2
Yourstruly
New User
 
Join Date: Oct 2017
Location: 'Bama
Posts: 2
Default

Originally Posted by eddy_911 View Post
Hi All,

I have read many ABS PSM lights thread and the consensus is that it could be caused by either MAF, Wheel Sensor, Air Filter being dirty, brake switch. I have a sort of different situation.

I noticed that the ABS and PSM lights only come on during cold temperature (say 45 F or below) and it doesnt come on when warm even driver after 40 minutes or so.

I changed the air filter tonight and noticed that the airbox was full of dirt.

I went for a drive afterward and the lights did not come on (temp is above 85F).

Also, i know that my brake lights are working so I am ruling out the brake switch issue.

The only thing left is the MAF and wheel sensors. Since the lights are coming on when cold, do you guys agree that the MAF is more likely to be the issue than wheel sensors?

Thanks for reading.
I have the same problem. It usually goes away when I cycle the key, but I want to find a solution.
Yourstruly is offline  
Reply With Quote
 

Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
magelin
996 Turbo Forum
18
11-01-2017 04:08 PM
tx targa
996 Forum
8
08-25-2017 08:21 PM
02Z06
996 Forum
1
05-31-2016 11:20 AM
healey1968
996 Forum
23
04-21-2016 07:16 PM
Byron in MS
996 Turbo Forum
6
02-03-2016 12:56 PM

Thread Tools
Search this Thread
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -3. The time now is 05:30 AM.


Copyright ę 1998 - 2017 Rennlist.com We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: