ABS PSM light only when cold - Rennlist - Porsche Discussion Forums

996 Forum
Sponsored by:
Sponsored by: LN Engineering

ABS PSM light only when cold

Reply

Old 05-18-2017, 11:29 PM
  #1  
eddy_911
User
Thread Starter
 
Join Date: Apr 2017
Posts: 32
Default ABS PSM light only when cold

Hi All,

I have read many ABS PSM lights thread and the consensus is that it could be caused by either MAF, Wheel Sensor, Air Filter being dirty, brake switch. I have a sort of different situation.

I noticed that the ABS and PSM lights only come on during cold temperature (say 45 F or below) and it doesnt come on when warm even driver after 40 minutes or so.

I changed the air filter tonight and noticed that the airbox was full of dirt.

I went for a drive afterward and the lights did not come on (temp is above 85F).

Also, i know that my brake lights are working so I am ruling out the brake switch issue.

The only thing left is the MAF and wheel sensors. Since the lights are coming on when cold, do you guys agree that the MAF is more likely to be the issue than wheel sensors?

Thanks for reading.
eddy_911 is offline  
Reply With Quote
Old 01-13-2018, 11:33 AM
  #2  
Yourstruly
New User
 
Join Date: Oct 2017
Location: 'Bama
Posts: 3
Default

Originally Posted by eddy_911 View Post
Hi All,

I have read many ABS PSM lights thread and the consensus is that it could be caused by either MAF, Wheel Sensor, Air Filter being dirty, brake switch. I have a sort of different situation.

I noticed that the ABS and PSM lights only come on during cold temperature (say 45 F or below) and it doesnt come on when warm even driver after 40 minutes or so.

I changed the air filter tonight and noticed that the airbox was full of dirt.

I went for a drive afterward and the lights did not come on (temp is above 85F).

Also, i know that my brake lights are working so I am ruling out the brake switch issue.

The only thing left is the MAF and wheel sensors. Since the lights are coming on when cold, do you guys agree that the MAF is more likely to be the issue than wheel sensors?

Thanks for reading.
I have the same problem. It usually goes away when I cycle the key, but I want to find a solution.
Yourstruly is offline  
Reply With Quote

Thread Tools
Search this Thread

Contact Us Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: