Rennlist - Porsche Discussion Forums

Rennlist - Porsche Discussion Forums (https://rennlist.com/forums/)
-   964 Forum (https://rennlist.com/forums/964-forum-59/)
-   -   New owner help, please! (https://rennlist.com/forums/964-forum/821417-new-owner-help-please.html)

Chris R. 06-24-2014 09:42 AM

New owner help, please!
 
2 Attachment(s)
Good morning guys,

I just picked up a real beauty of a 964 after having been looking for about a month or so. This is my first air cooled 911...still have a 996GT3 as my track car and am selling my 06 Cayman S (yet another track car). I wanted a fun, classic street car...hence this 1990 C2.
That being said, though I have been around these cars forever I don't know enough about them yet.
I don't have the owners manual and am trying to find onto buy, copy or download (anyone?) but I have the "red !" that goes on in the dash very time I start it....I don't know why. How do I know what the "problem" is?
I know i'll get the :rtfm: emoticon...I would if I had one!!
Thanks.
Oh and pics with my race bike on top.

gsxr_fvr 06-24-2014 09:47 AM


Originally Posted by Chris R. (Post 11462588)
Good morning guys,

I just picked up a real beauty of a 964 after having been looking for about a month or so. This is my first air cooled 911...still have a 996GT3 as my track car and am selling my 06 Cayman S (yet another track car). I wanted a fun, classic street car...hence this 1990 C2.
That being said, though I have been around these cars forever I don't know enough about them yet.
I don't have the owners manual and am trying to find onto buy, copy or download (anyone?) but I have the "red !" that goes on in the dash very time I start it....I don't know why. How do I know what the "problem" is?
I know i'll get the :rtfm: emoticon...I would if I had one!!
Thanks.
Oh and pics with my race bike on top.

Does it remain on even after turning the car on? Make sure your hand brake is all the way down..even if its left slightly up it'll throw the "!"
Also congrats, welcome and you definitely lucked out with the Aero mirrors..

deutschland-dobson 06-24-2014 09:51 AM

Great looking '64 you have there!

Do you get a warning buzzer, or just the "!" symbol?

Chris

Chris R. 06-24-2014 10:03 AM

The light comes on when I start it, no other light accompanies it. No buzzer. Oil level is good, fluids are good...brakes are good...
When cold, it makes a strange "squelching" noise from under the shifter...not sure what that is. I don't think it's related since the "!" comes on even when the car is warm. Drives fine though...
Thanks for the help.

Merle 06-24-2014 10:12 AM

Does the spoiler light come on as well? Does the ! light turn off after you start driving? This is normal if so. Mine does it too. The ! light is a warning light to let you know there is another light on.

yellowducman 06-24-2014 10:24 AM

Mine comes on when the car is started and doesn't go off until the car start moving. I thought it was normal.

Chris R. 06-24-2014 10:25 AM

It will come on and stay on unless I press the button in front of the shifter; then it will remain off until I re-start the car.
I feel like we are on 20 questions...lol!

boxsey911 06-24-2014 10:40 AM


Originally Posted by Chris R. (Post 11462680)
It will come on and stay on unless I press the button in front of the shifter; then it will remain off until I re-start the car.
I feel like we are on 20 questions...lol!

Yes it will probably be 20 questions for a while because the 'i' staying on will be accompanied by another warning light. e.g. when the low fuel light comes on the 'i' comes on with it. I've never seen an 'i' is on its own but I guess that it could be indicating a fault elsewhere that might be unique to a Canada 964? I believe you have DRLs on canada 964s so maybe there is a problem with those?

Andy Roe 06-24-2014 10:47 AM

If you're getting the central warning light then you should also have another light indicating why its on. Since you do not also have the buzzer sounding, it could be one of the following:
Brake Fluid Level
Handbrake
Fan Belt
Oil Pressure
Low Fuel
Rear Spoiler

When you turn the ignition on (without starting the car) are all of these lit up?

Lemass Automotive 06-24-2014 11:29 AM

ABS sensor?

LouZ 06-24-2014 11:55 AM

Take a look if you have bulbs in the seatbelt and airbag icons on the clock (both should light up when you turn on the key). it is common for the P.O. to remove them. The cause is generally cold solder joints on the board of the gauge and the remedy is to simply solder them, there are plenty of posts and DIY's on the subject.

vagluv 06-24-2014 03:31 PM

I used to have the same symptoms, caused by a faulty seatbelt sensor. Cleared up when I swapped my steering wheel and installed the airbag bridge adapter.

Richard Curtis 06-24-2014 07:16 PM

What LouZ said. Also do a search in this forum; somewhere I've seen the gauge diagrams that show all the warning lights you should see when ignition is switched to "on."

Also: buy a copy of Adrian Streather's book on the 964. Tough to find one (it's out of print I believe) but worth whatever you have to pay.

Chris R. 06-25-2014 07:48 AM

Aha! I have an aftermarket steering wheel, without the airbag.....I bet that's it. :)

vagluv 06-25-2014 02:47 PM


Originally Posted by Chris R. (Post 11465059)
Aha! I have an aftermarket steering wheel, without the airbag.....I bet that's it. :)

Get the bridge adapter, it's about $15 iirc. 5 minute install.


All times are GMT -3. The time now is 06:35 PM.


© 2019 MH Sub I, LLC dba Internet Brands