Notices
928 Forum
Sponsored by:
Sponsored by: 928 Specialists

Dash lights only work when lights off

 
Old 11-10-2010, 03:53 PM
  #16  
rligeti
User
 
rligeti's Avatar
 
Join Date: Sep 2002
Location: Roseville, CA
Posts: 310
Default

Originally Posted by Oli928 View Post
The only other items I saw during my 45-minute search to see if this topic already had a thread was:

1) Apparently there is a cluster of wires/connections (behind/below?) the clock...someone said to pull the ashtray unit out and check all connections behind there and clock area. Also, maybe something got disconnected during radio swap/re-installation work?

2) Another post said to pull every fuse related to lights and not just check them visually, but check them with a meter for continuity.

3) ...the obvious, check to see if wire at dimmer is shorted to ground or has too much resistance (dreaded green wire syndrome). My wire to the fuel pump had the green monster...had to run new one a few months ago.

4) Possibly the light sensor above the gear indicator lights is causing a fault (I may have misread this...might be related to some other issue). The person said to shine a flashlight unto the sensor to see if the dash dims when they are on.

5) Related to stereo work / someone may have tried to connect an aftermarket radio's light to the headlight switch fuse area and shorted/disconnected something by accident.

Again, I only searched for about 45 minutes; there may be other threads that answer this better.
Great research, thanks for putting in the time and effort!

Best,
Rob
rligeti is offline  
Old 11-22-2010, 12:21 PM
  #17  
Oli928
User
Thread Starter
 
Oli928's Avatar
 
Join Date: Jul 2010
Location: South Texas
Posts: 71
Default

Found the problem
It was as suspected...the dimmer for the dash.
I bypassed the dimmer and all the lights came on that were suppose to when parking lamps or headlamps are on.

I'm going to order a dimmer...didn't look easy to replace though, without taking apart more stuff. I'm going to get a small mirror to see what holds it in place.

Thanks for everyone's help
Oli928 is offline  
Old 11-23-2010, 06:01 PM
  #18  
Oli928
User
Thread Starter
 
Oli928's Avatar
 
Join Date: Jul 2010
Location: South Texas
Posts: 71
Default

I forgot to mention a few observations.

1) My digital clock started to show time (first since I bought the car in March), but only with parking/headlights on. I'm guessing there is a loose connection on the back???
2) Does anyone know if the aux a/c dials have a back-light?
3) How about the digital clock back-light?
4) How about main a/c fan switch?
5) How about the headlight switch?
...these are the only switches which don't light up/don't know if they are supposed to

I did notice the seat memory buttons also now light up.
Oli928 is offline  
Old 11-23-2010, 06:20 PM
  #19  
Alan
Electron Wrangler
Lifetime Rennlist
Member
 
Alan's Avatar
 
Join Date: Mar 2002
Location: Phoenix AZ
Posts: 11,930
Default

Originally Posted by Oli928 View Post
I forgot to mention a few observations.

1) My digital clock started to show time (first since I bought the car in March), but only with parking/headlights on. I'm guessing there is a loose connection on the back??? >>>YES Sounds likely
2) Does anyone know if the aux a/c dials have a back-light? >>>No - they are just black plastic ***** - (pull them off)
3) How about the digital clock back-light? >>>YES
4) How about main a/c fan switch? >>>No (AC on/off switch yes)
5) How about the headlight switch? >>>YES (always on with ignition)
...these are the only switches which don't light up/don't know if they are supposed to

I did notice the seat memory buttons also now light up.
Alan
Alan is offline  
Old 11-23-2010, 06:29 PM
  #20  
Oli928
User
Thread Starter
 
Oli928's Avatar
 
Join Date: Jul 2010
Location: South Texas
Posts: 71
Default

Thanks for the quick/informative response. Your answers are pretty much what I figured, except for the headlight dial...I figured that should be lit when headlights are on so you can find it quick, in case you want to turn off. I see Porsche's logic though...
I read somewhere to pull out the ashtray assembly to check the clock lights / I'll post my results. Glad to know the clock works though, I almost bought a used one for $$$...I figured it went bye, bye / wasn't meant to work 21+years...
Oli928 is offline  
Old 12-04-2011, 09:58 PM
  #21  
Rob Edwards
Archive Gatekeeper
Rennlist Member
 
Rob Edwards's Avatar
 
Join Date: Sep 2002
Location: Irvine, CA
Posts: 13,681
Default

Drove the GTS for the first time in about a month yesterday, and coming home at dusk realized that I had no lights for anything in the center console (HVAC head, clock, ashtray). A few weeks ago, I did take apart the steering column a bit to see how it all goes together, perhaps that wasn't such a good idea...

Don't recall touching the dimmer but obviously will have to double check. I hates them electrons....
Rob Edwards is offline  
Old 12-21-2011, 05:55 PM
  #22  
aaron3
User
 
Join Date: Jan 2002
Posts: 179
Default

I have seen this problem pop up a number of times. I had this problem also, but I figured it out. Here's my official trouble shooting write-up:

Problem: Dash lights (the back lighting) go out when headlights are on. Dash light works fine when headlights switched off. Digital dash display works fine in all cases, this is a back-lighting problem only.

Car: 90GT

Fix: There is a connector on the firewall above the foot pedals. This connector gets loose (it does not come off). Wiggle the connector and you get the lights back. You need to lay on your back with your head/back where your feet normally are (not an easy position). The connector is right on the firewall and pretty high up above the pedals (not easy to see). Have not permanently fixed it so I need to get under there and push the connector on every now and then.

Try this before you tear out your pod or the dimmer.
aaron3 is offline  
Old 12-22-2011, 01:02 AM
  #23  
Alan
Electron Wrangler
Lifetime Rennlist
Member
 
Alan's Avatar
 
Join Date: Mar 2002
Location: Phoenix AZ
Posts: 11,930
Default

You could always check the fuse - fuse 44 on an '88/'89, fuse 9 on a '94 GTS

Alan
Alan is offline  
Old 12-22-2011, 01:04 PM
  #24  
Jchiodi
User
 
Jchiodi's Avatar
 
Join Date: May 2011
Location: West Chester Ohio
Posts: 262
Default

I have similar problem on MY 86. Only time I've seen the intruments lit was when I had passenger side headlight burn out! when that was fixed they didnt work again.

It's on a long list of things to do this winter!
Jc
Jchiodi is offline  
Old 12-22-2011, 10:44 PM
  #25  
Gregg K
User
 
Gregg K's Avatar
 
Join Date: Apr 2003
Location: Mendocino
Posts: 1,254
Default

Still no solution. I have an 89. There is no connector on the firewall. The dash dimmer varies between around 5-15 ohms (or kohms, didn't look). No blown fuses.

Unless I get some help here I'll be driving around without dash lights.
Gregg K is offline  
Old 07-27-2012, 11:50 PM
  #26  
Fontana
User
 
Fontana's Avatar
 
Join Date: May 2012
Location: Monroe, NY 10950
Posts: 269
Default

Okay...?
Fontana is offline  
Old 04-13-2019, 09:51 AM
  #27  
Kevin in Atlanta
Addict
Rennlist Member
 
Join Date: May 2002
Location: Roswell, GA
Posts: 5,143
Default

Originally Posted by aaron3 View Post
I have seen this problem pop up a number of times. I had this problem also, but I figured it out. Here's my official trouble shooting write-up:

Problem: Dash lights (the back lighting) go out when headlights are on. Dash light works fine when headlights switched off. Digital dash display works fine in all cases, this is a back-lighting problem only.

Car: 90GT

Fix: There is a connector on the firewall above the foot pedals. This connector gets loose (it does not come off). Wiggle the connector and you get the lights back. You need to lay on your back with your head/back where your feet normally are (not an easy position). The connector is right on the firewall and pretty high up above the pedals (not easy to see). Have not permanently fixed it so I need to get under there and push the connector on every now and then.

Try this before you tear out your pod or the dimmer.

I cannot find this on my 90. Anyone have pictures?
Kevin in Atlanta is offline  
Old 04-21-2019, 02:05 PM
  #28  
pmooradian
User
 
pmooradian's Avatar
 
Join Date: Nov 2003
Location: Fairfield, CA
Posts: 237
Default Same problem

I've been dealing with the same problem on my'89 for a while. Now it's happening on my GTS. Dash lights work fine when lights are off but go dark when the parking lights or regular lights are switched on. My dimmer works with the console lights, which are still working so I'm not sure how that would be a problem. Guess I'll try and figure it out today.
pmooradian is offline  
Old 04-21-2019, 04:52 PM
  #29  
Kevin in Atlanta
Addict
Rennlist Member
 
Join Date: May 2002
Location: Roswell, GA
Posts: 5,143
Default

Originally Posted by pmooradian View Post
I've been dealing with the same problem on my'89 for a while. Now it's happening on my GTS. Dash lights work fine when lights are off but go dark when the parking lights or regular lights are switched on. My dimmer works with the console lights, which are still working so I'm not sure how that would be a problem. Guess I'll try and figure it out today.
Welcome to my world. Let us know if you fix it. Not sure the popo will believe me that at night I don't know how fast I am going.
Kevin in Atlanta is offline  

Thread Tools
Search this Thread
Quick Reply: Dash lights only work when lights off


Contact Us - About Us - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: