Notices
928 Forum
Sponsored by:
Sponsored by: 928 Specialists

Clutch Rattle

 
Old 07-04-2010, 08:24 PM
  #46  
Hilton
Super User
 
Hilton's Avatar
 
Join Date: Jun 2006
Location: ɹəpun uʍop 'ʎəupʎs
Posts: 6,102
Likes: 0
Received 1 Like on 1 Post
Default

Originally Posted by 9x8 View Post
Once again I'm amazed by the mass of knowledge that is accumulated in this forum.
I had the same issue as the OP after I put the clutch back together in my 90 GT. The clutch fork seemed to have excessive back-to-forward free play and rattled somewhat unless I preloaded it by pressing clutch pedal. I was afraid that I had to tear it down again, but after reading the above post I'm pretty sure that I just have bad slave cylinder - it does not preload the arm correctly.
You can adjust the preload for the clutch hydraulic system at the clutch master in the footwell.

Instructions are in the workshop manual.. page 30-1

I had a problem with the clutch in my '89 - turns out there was too much preload and it wasn't quite opening the return port in the master. Adjusting preload correctly, then the helper spring, gives the clutch a really nice light action.
Hilton is offline  
Old 07-05-2010, 07:21 AM
  #47  
9x8
User
 
9x8's Avatar
 
Join Date: Apr 2009
Location: The Evil Empire.
Posts: 497
Likes: 0
Received 0 Likes on 0 Posts
Default

Originally Posted by Hilton View Post
You can adjust the preload for the clutch hydraulic system at the clutch master in the footwell.

Instructions are in the workshop manual.. page 30-1
Yep, that's what I did for now.
Although it looks like I will have to tear it down again anyway - to replace the guide tube.
9x8 is offline  
Old 02-01-2014, 08:29 PM
  #48  
granprixweiss928
Addict
Rennlist Member
 
granprixweiss928's Avatar
 
Join Date: Jun 2013
Location: Norcal
Posts: 1,329
Likes: 0
Received 0 Likes on 0 Posts
Default

I think I have a similar issue. I pulled my lower cover today to see the clutch the first time. First notice is grease everywhere. its this OK? Clutch rotating mass seems dry. I have a rattle when I engage the clutch and start the car moving. if I "pump" the pedal ( grab, ungrab, grab) it makes the sound.

I did find here that my ball cup on the fork arm is shot. is the play around the TOB ok?

granprixweiss928 is offline  
Old 02-01-2014, 09:59 PM
  #49  
Mrmerlin
Petie3rd
Rennlist Member

This Post Sponsored by:
Dow Corning« & DeoxIT«
 
Mrmerlin's Avatar
 
Join Date: May 2004
Location: Philly PA
Posts: 22,753
Received 3 Likes on 2 Posts
Default

the busing has failed,
replace it,
make sure to clean out the seating area on the arm use a sharp object to remove the crusty plastic.
Press the new bushing onto the ball then fit the arm socket
Mrmerlin is offline  

Thread Tools
Search this Thread
Quick Reply: Clutch Rattle


Contact Us - About Us - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: