Go Back  Rennlist - Porsche Discussion Forums > Water Cooled Technical Discussion Areas > 997 Forum
Reload this Page >

997.2 - Funky Problem with Oil Pressure???, Looking for Suggestions

Notices
997 Forum
Sponsored by:
Sponsored by:

997.2 - Funky Problem with Oil Pressure???, Looking for Suggestions

 
Old 05-16-2019, 06:15 PM
  #1  
MOXY_997.2
Addict
Rennlist Member
Thread Starter
 
Join Date: Nov 2018
Location: Louisville, KY
Posts: 30
Default 997.2 - Funky Problem with Oil Pressure???, Looking for Suggestions

My son and I were out driving my 2010 997.2 two last week. Oil pressure on the gauge was running 2.5 to 3.0 on the gauge while driving. When came to a stop at a light and the pressure on the gauge went to "0" and a warning came up that said something like, "Oil Pressure Monitoring System defective - malfunction". We pulled to the side of the road (pressure went back to normal) and shut the car off. The next day we took it to a local indy and they worked with the oil sending unit harness, problem still present. They then replaced the oil sending unit and the problem is still present. They are going to look into taking a manual pressure tomorrow to see if the pressure is actually dropping.

Has anyone here ever heard of a problem like this one? Thanks in advance for any suggestions?
MOXY_997.2 is offline  
Old 05-17-2019, 11:35 AM
  #2  
Petza914
Addict
Rennlist Member
 
Petza914's Avatar
 
Join Date: Oct 2007
Location: Clemson, SC
Posts: 10,655
Default

I believe the 997.2 has a variable oil pressure pump, vs the fixed style in the 997.1. Wayne Smith knows more about how the .2 one works, I'm not sure what it uses for criteria to make it vary the pressure, but could be a sensor related to that could have gone bad. Obviously you don't want to drive a car that's not making any oil pressure and not knowing if the gauge, sender, or pump might be the culprit, don't start it again until that's determined.
Petza914 is offline  
Old 05-17-2019, 11:49 AM
  #3  
TheBruce
Addict
Rennlist Member
 
TheBruce's Avatar
 
Join Date: Feb 2017
Location: San Francisco
Posts: 1,289
Default

Hmm. Yea that's one you definitely dont want to mess around with until its solved. Does it only drop when idling? What was your oil temp? I dont have any experience with the .2 so take my comments as a reference point only. I wrote a post a while back asking for guys to share their oil pressures and some of the .2 guys chimed in. I will try to find it.

On the .1 2.5 bars would also on the low-end while driving, unless you're puttering around. Im usually at 4-5 bars but I have a 6sp and tend to stay in the fun zone most of the time. The .1 manual says you should be >3.5 bar at 5k rpm. It doesn't give an recommendation for idling. When my car is cold it idles at 5 bar then will drop to around 2-3 once its warmed up a bit. If im getting on it and my oil temp is 210-220 it will idle at 1 bar.

Hopefully its just something with the sender. Given the CEL, it seems to point that way. Hopefully some of the pros can comment on other areas to look at. I would assume the next item on the list is the oil pump.

If its ends up being something mechanical I would have them change the oil, check the filter and scope the bores...but I tend to be neurotic.
TheBruce is online now  
Old 05-17-2019, 12:57 PM
  #4  
Wayne Smith
Addict
Rennlist Member
 
Wayne Smith's Avatar
 
Join Date: Oct 2014
Posts: 2,430
Default

Edit ... Sorry, just reread your post and realized your car didn't auto heal (replaced sender and problem still exists). I now assume you flat bedded the car to the dealer. I'd worry about number 4 on the list below. Anyway, the following is my unedited initial post that assumed you drove the car home without mechanical failure ...

The 997.2 has scavenger pumps at each corner of the oil pan. These pumps supply oil to an internal chamber that contains another pump. The chamber pump supplies an outlet unit that contains multiple proportional control valves. The valves automatically adjust pressure individually to various parts of the motor based upon operating conditions ... Computer controlled.

So there is no single oil pressure on a 997.2.

I can't tell you what the oil pressure gauge indicates on these cars. From what I've experienced it's kind of a dummy system (like the water temperature gauge that always reads 175F).

Going to 0 would, IMHO, represent one of the following ...

1. The internal chamber (I'm referring to it this way rather than a sump because some will state that a sump system must be external to the motor) went dry. Thus all pressure stopped. The oil would need to be incredibly low for this to occur.

2. The chamber pump failed. It is unlikely it would auto recover.

3. All four scavenger pumps failed. I'm not a big believer in two simultaneous failures let alone four.

4. The proportional control unit stopped operating. It is unlikely it would auto recover.

5. The pressure sender (from whatever part of the oiling system that is attached to) failed. Again, not likely to recover.

6. A connection to or from the sensor failed. This could Auto recover. Note: There is no such thing as a good connection!!! Connections go bad and self heal. They are very possibly the biggest problem in electrical systems (bad connections not only cause systems to stop operating but can also cause spikes that damage good components).

7. The computer glitched and required a reset.

I'm voting for number 7, but there may be others. Keep us updated.
Wayne Smith is online now  
Old 05-17-2019, 01:08 PM
  #5  
Iceter
User
 
Iceter's Avatar
 
Join Date: Feb 2012
Location: Raleigh, North Carolina
Posts: 1,836
Default

Wayne, that's fascinating information. Thank you for the explanation.

Do you know where the gauge pressure is measured? With multiple pressures coming off of the proportoning valves (and the resulting multiple failure points) I'm really curious about where a relevant pressure could be measured.
Iceter is online now  
 


Thread Tools
Search this Thread

Contact Us - About Us - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: