Alt light on and some instruments don't work - Rennlist - Porsche Discussion Forums

Go Back  Rennlist - Porsche Discussion Forums > Turbo Technical Discussion Areas > 993 Turbo Forum
Reload this Page > Alt light on and some instruments don't work
Notices

Alt light on and some instruments don't work

Reply

Old 03-06-2017, 07:45 PM
  #1
nbenn911
User
Thread Starter
 
nbenn911's Avatar
 
Join Date: Jun 2007
Location: Western Arkansas
Posts: 18
Default Alt light on and some instruments don't work

I have a new problem on my 993TT. I haven't driven it much this winter, but has been on a trickle charger. When I drove it about a week ago the alternator (little battery shaped) light came on and some of the instruments did not work initially, but after a couple of miles down the road the light went out and all instruments worked normal. The same thing happened when I drove it yesterday. The car starts and runs fine, but the tach and speedometer lights, etc did not work initially. Do you guys know what the deal is. I live in FS, AR and usually have to go to Tulsa for service. Thanks
nbenn911 is offline  
Reply With Quote
Old 03-07-2017, 11:08 AM
  #2
carguy19
User
 
Join Date: Jun 2016
Posts: 163
Default

Check the alternator/fan belt first. It could be on its way out and slipping.

If not I'd look at the alternator next along with checking the battery with a load test (can be done at any mechanic or auto zone/pep boys)
carguy19 is offline  
Reply With Quote
Old 03-07-2017, 11:17 AM
  #3
LexVan
Addict
Rennlist Member
 
LexVan's Avatar
 
Join Date: Jan 2013
Location: Chicagoland Area
Posts: 15,120
Default

Hope no mouse damage. Start looking/sniffing around.
LexVan is offline  
Reply With Quote
Old 03-07-2017, 04:15 PM
  #4
carguy19
User
 
Join Date: Jun 2016
Posts: 163
Default

Originally Posted by LexVan View Post
Hope no mouse damage. Start looking/sniffing around.
This too. I dont know why mice find Porsche wires so delicious. I've had to fix damage on one of my previous cars from a nest of mice that hung out for the winter.
carguy19 is offline  
Reply With Quote
Old 03-08-2017, 10:13 PM
  #5
nbenn911
User
Thread Starter
 
nbenn911's Avatar
 
Join Date: Jun 2007
Location: Western Arkansas
Posts: 18
Default

Thanks for the ideas! I will have a chance to look at it this weekend and will let you know what I find out. I hope it is not mice as I have dealt with them on a vehicle before. Geez!
nbenn911 is offline  
Reply With Quote
Old 03-08-2017, 10:15 PM
  #6
nbenn911
User
Thread Starter
 
nbenn911's Avatar
 
Join Date: Jun 2007
Location: Western Arkansas
Posts: 18
Default

Oh, by the way, how do I get my ugly mug off here? I do not remember doing that...maybe I was drunk!
nbenn911 is offline  
Reply With Quote
 

Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
van883
928 Forum
4
09-15-2017 03:55 AM
MJP911
Boxster & Boxster S (986) Forum
6
07-01-2017 12:00 PM
rirvine
996 Forum
0
06-05-2017 06:37 PM
Dwayne
928 Forum
25
02-10-2017 09:52 AM
yoramw
924/931/944/951/968 Forum
13
01-22-2017 10:05 AM

Thread Tools
Search this Thread
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -3. The time now is 08:03 AM.


Copyright ę 1998 - 2017 Rennlist.com
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: