Battery replacement 987 issues - Rennlist - Porsche Discussion Forums

Notices
987 - 981 Forum
Sponsored by:
Sponsored by:

Battery replacement 987 issues

Old 12-31-2017, 06:57 AM
  #1  
Rabid_ant
User
Thread Starter
 
Join Date: Dec 2017
Posts: 9
Default Battery replacement 987 issues

Hi all, i'm new to the group and seem to have picked up my first issue on my 05 987. So i've hunted and read loads online and see that this can cause copious issues. So my battery died....my fault, left the key on the ignition by accident. Removed it, charged it up and returned it. Started it up, and the usual happened. PSM warning, no stress. Drove the car round the block, PSM warning disappeared but then kicked me a second error "go to dealer" etc. got home, and turned it off. ALAS...key stuck in the ignition. got that out through the lock and ignition wouldn't switch off. ......problem. Solution, disconnect the battery again and reconnect. now the ignition wont switch on when i insert the key, and the key locks in place every time i put it in. But its just completely dead when inserting the key. Car will also not lock or unlock with the remote anymore. multiple sadness......anything i should be looking at trying?
Rabid_ant is offline  
Old 12-31-2017, 07:34 AM
  #2  
Rabid_ant
User
Thread Starter
 
Join Date: Dec 2017
Posts: 9
Default

ok...so left it disconnected for a bit and reconnected now again. Key works...drove it to get rid of the PSM error and sorted, no other issues so far. Will have it checked in the new year anyway.
Rabid_ant is offline  
Old 12-31-2017, 01:07 PM
  #3  
Marine Blue
Addict
Rennlist Member
 
Marine Blue's Avatar
 
Join Date: Jul 2004
Location: Temecula, CA
Posts: 13,109
Default

The car should relearn all of the prior settings although sometimes the window settings may need some coaxing.
Marine Blue is offline  
Old 12-31-2017, 01:22 PM
  #4  
extanker
Banned
 
Join Date: Sep 2009
Posts: 2,184
Default

how old is the battery
extanker is offline  
Old 01-02-2018, 06:29 AM
  #5  
Rabid_ant
User
Thread Starter
 
Join Date: Dec 2017
Posts: 9
Default

Battery is new....strange again.....Car was fine for 2 days, did a long coast drive no issues. Stopped and started it a few times on the drive. Got home and let it stand for a bit...alas....got back top it, remote didnt work at all and upon inserting the key again, no ignition and the key locked in again. Tried everything, and finally disconnected the battery for 10 min. Re-connected it and all fine, no problem. Now i'm hesitant to use the car in case it gives the same issue again. I suspect a trip to the Stealers or a good indi at some stage.
Rabid_ant is offline  
Old 01-02-2018, 09:45 AM
  #6  
terbiumactivated
Banned
 
Join Date: Dec 2012
Location: Atlanta Ga
Posts: 1,210
Default

Were you using the same key? Both keys have to relearn and if memory serves me correctly inserting it into the door and leaving it there reprograms the key? That might not be correct I'm sure someone else can chime in on that.
terbiumactivated is offline  
Old 01-03-2018, 01:17 PM
  #7  
Rabid_ant
User
Thread Starter
 
Join Date: Dec 2017
Posts: 9
Default

So it continues....... got home this evening after pulling the car in on Monday. Neither remote will unlock the car, i have to manually unlock the door. Once in, i push the key into the ignition and nothing happens, no light or any activate, try turning to the right and nothing happens, and then the key is locked into the ignition. Steering is also locked. I suspect if i disconnect the battery, leave it for 10 min and try again it will work. Battery is showing a good 12.6 volts....any chances it can be the battery after leaving it for so long with the ignition on?
Rabid_ant is offline  
Old 01-03-2018, 03:54 PM
  #8  
Marine Blue
Addict
Rennlist Member
 
Marine Blue's Avatar
 
Join Date: Jul 2004
Location: Temecula, CA
Posts: 13,109
Default

It might be worth trying a different battery just to rule it out. If it fails you can always return the battery.

Also any chance the batteries in the keys are dying and causing issues?

I’m clearly just throwing ideas out there, hopefully someone else has come across this and can chime in with a better assessment.
Marine Blue is offline  
Old 01-12-2018, 10:23 AM
  #9  
Rabid_ant
User
Thread Starter
 
Join Date: Dec 2017
Posts: 9
Default

the pain......still no luck!!

Battery charged
Replaced remote batteries
checked all the fuses

It's almost as if the whole car is getting no power. only the clock on the dash, power windows ect have power. door lights don't illuminate, i can't open front or rear lids with the remote, but can from inside the car. Is there any main power relay into the car? remembering if i insert the key into the dash i get nothing. almost as if there's no power to the car other than the auxillaries? Can it be the immobilizer unit under the seat? i figured that only impacted starting post ignition, not before?

HELP!!!!!!!!!!
Rabid_ant is offline  
Old 03-04-2018, 10:35 AM
  #10  
sh944
Addict
Lifetime Rennlist
Member


Rennlist
Site Sponsor
 
Join Date: Jun 2002
Posts: 8,293
Default

Were you able to resolve this issue?
sh944 is offline  
Old 03-07-2018, 10:47 AM
  #11  
Rabid_ant
User
Thread Starter
 
Join Date: Dec 2017
Posts: 9
Default

Originally Posted by sh944 View Post
Were you able to resolve this issue?
Indeed ....a semi costly exercise but it has been sorted. Turns out the PAS (Porsche Access System) module was intermittently toast so had to be replaced. Both keys had to be reprogrammed too so had to go to the dealership to get sorted. Not a cheap or fun exercise. Parts had to be shipped in from Germany.
Rabid_ant is offline  
Old 03-07-2018, 12:40 PM
  #12  
Mrg02D
User
 
Join Date: Sep 2016
Posts: 79
Default

Originally Posted by Rabid_ant View Post
Indeed ....a semi costly exercise but it has been sorted. Turns out the PAS (Porsche Access System) module was intermittently toast so had to be replaced. Both keys had to be reprogrammed too so had to go to the dealership to get sorted. Not a cheap or fun exercise. Parts had to be shipped in from Germany.
So what caused PAS module to fail?
Mrg02D is offline  
Old 03-07-2018, 01:08 PM
  #13  
Rabid_ant
User
Thread Starter
 
Join Date: Dec 2017
Posts: 9
Default

Originally Posted by Mrg02D View Post


So what caused PAS module to fail?
left the ignition on overnight..... post that was cooked 😱
Rabid_ant is offline  
Old 03-10-2018, 05:49 PM
  #14  
sh944
Addict
Lifetime Rennlist
Member


Rennlist
Site Sponsor
 
Join Date: Jun 2002
Posts: 8,293
Default

Ouch, that sucks! I am always wary of leaving the key in the ignition if I am not driving the car, that will just add to my paranoia.

At least you are driving again! Thanks for the update.
sh944 is offline  


Thread Tools
Search this Thread
Quick Reply: Battery replacement 987 issues


Contact Us Advertising Cookie Policy Privacy Statement Terms of Service

© 2018 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: