Notices

rough idle when warm

 
Old 04-17-2019, 03:21 PM
  #1  
blopper
User
Thread Starter
 
Join Date: Jun 2004
Posts: 35
Default rough idle when warm

Hi all, I let my 968 sit for a while over the last 5 years. Finally getting a chance to use the car again. The problem I am having is when the engine comes up to operating temp, it starts to miss at idle and stumble real bad when applying throttle. If I come up slowly. say to 3000 rpm, the engine runs smooth and flawless. If I hold the pedal to around 2500 rpm or less, it will stumble and eventually stall. The warmer the engine gets, the worse the problem.

So far I have changed the injectors with new because one of them was stuck closed. It starts up cold no problem. Fresh gas, replaced the fuel filter, and just replaced the O2 sensor. From reading, it sounds like the engine is fine during open loop operation. What should I be looking at next, I don't have a fuel pressure gauge right know because I don't really feel like it is a pump or regulator problem as the issue is consistent at warm up.
Thanks, Don
blopper is offline  
Old 04-17-2019, 04:29 PM
  #2  
blopper
User
Thread Starter
 
Join Date: Jun 2004
Posts: 35
Default

I think I may have asked for help too soon. I found lots of water/moisture down in the spark plug access areas. Dried wires and holes and so far so good. Odd that it would only act up when the engine approached warm.
blopper is offline  
 


Thread Tools
Search this Thread

Contact Us - About Us - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: