Notices
964 Forum
Sponsored By:
Sponsored By:

Why is my gas mileage so crappy?

 
Old 02-08-2018, 07:48 PM
  #1  
Alex Sol
User
Thread Starter
 
Alex Sol's Avatar
 
Join Date: Sep 2006
Location: Toronto
Posts: 620
Default Why is my gas mileage so crappy?

I didn't buy this car because I wanted to save money on gas. I would have kept my Honda... but... i used to get 300 kms on the half way mark then get to about 500kms before the light would go on. I would be driving mostly highway doing this of course. In fact got just shy of 650kms running on fumes before i did the rebuild. Now i'm luck to get 225-250 at the halfway mark with the fuel light coming on about 400-425kms.

Some of the stuff i've done:

plugs, wires, rotors, hats, fresh distributor rebuild
coils -running msd
fuel - the 91 octane we get here in Toronto
Air Filter - EvoMS with K&N Cone
Exhaust - no cat, primary, no secondary
Emissions - passed with no problems (just thought i'd throw that in)
Ignition - all stock ECU with some 911 chip that came with the car... i've had this ten years now...

Am i running rich? doesn't smell like it and passed emissions....
Due to no Cat? Lack of back pressure from ditching the secondary? I cut the primary pipe and rewelded a tip roughly 90* directly out the back so looks more or less stock

thoughts?

Idle - purrs like a kitten though a slight hunt from 850 rpm to 900rpm every so often
Alex Sol is offline  
Old 02-08-2018, 09:28 PM
  #2  
Rocket Rob
IHI KING!
Rennlist Member

 
Rocket Rob's Avatar
 
Join Date: Aug 2001
Location: Nashua, New Hampshire, USA
Posts: 12,509
Default

Have you checked for a dragging brake? I would jack up the car and see if each wheel spins freely.
Rocket Rob is online now  
Old 02-08-2018, 10:24 PM
  #3  
murphyslaw1978
Super User
 
murphyslaw1978's Avatar
 
Join Date: Aug 2006
Location: Chicago, IL
Posts: 4,698
Default

Are you running a thicker or different brand oil than before? Did you make any changes to the fuel tank sending unit? Has the outside air temperature changed at all?
murphyslaw1978 is offline  
Old 02-08-2018, 11:52 PM
  #4  
Mike Hollinger
User
 
Mike Hollinger's Avatar
 
Join Date: Mar 2014
Location: Jamestown, Rhode Island
Posts: 5
Default

Did you pull the oxygen sensor when the converter came out? A failed (or missing) sensor might send the fuel injection computer into an open loop, full rich mode. Don’t know how that jives with passing an emissions test but might be a possibility.
Mike Hollinger is offline  
Old 02-09-2018, 08:34 PM
  #5  
Alex Sol
User
Thread Starter
 
Alex Sol's Avatar
 
Join Date: Sep 2006
Location: Toronto
Posts: 620
Default

all very good tips.

I'll check the brakes though 90% sure they are spinning freely.

I replaced o2 sensor brand new about a year ago and still have my cat only nothing inside it... doh!

I'm running 10w50 castrol edge synthetic... which is better than i was running. previously burning and spilling so much oil that i would just top up every 500kms so that might not be it.

Also the temps are cold here in the late fall, i haven't been driving much in the winter... even with my snow tires.... and didn't notice any change from summer to fall...

Thanks for the few things to check first...
Alex Sol is offline  
Old 02-10-2018, 09:59 AM
  #6  
Rocket Rob
IHI KING!
Rennlist Member

 
Rocket Rob's Avatar
 
Join Date: Aug 2001
Location: Nashua, New Hampshire, USA
Posts: 12,509
Default

When you changed the spark plugs, were they all the same color? Could you have a leaky injector?
Rocket Rob is online now  
Old 02-10-2018, 12:56 PM
  #7  
djantlive
Super User
 
djantlive's Avatar
 
Join Date: Oct 2004
Posts: 2,407
Default

Tire pressure? Transmission oil changed? Run a tank of fuel cleaner
djantlive is offline  
Old 02-10-2018, 02:57 PM
  #8  
Jjm4life
User
 
Join Date: Nov 2012
Location: Boston
Posts: 1,490
Default

This thread makes me think my mileage is worse than it should be..
Jjm4life is offline  
Old 02-11-2018, 10:49 PM
  #9  
-nick
Addict
Rennlist Member
 
-nick's Avatar
 
Join Date: Feb 2003
Location: Cambridge/Boston, MA
Posts: 1,362
Default

It doesn’t look bad to me, but if you’re driving the exact same routes and notice a drop then something might be going on. If you let it idle to warm, then that would account for some of it. Cold start/warm up mix is very rich and it takes a while to warm all 12qts of oil. Winter fuel blends can also decrease mileage slightly, so I’ve heard. Any additional city driving mixed in to your routine will reduce mileage pretty quickly.

Personally, I’ve gotten anywhere from single-digit mpg (winter and all short trips in the city) to a consistent 22mpg for all highway at 80mph.
-nick is offline  
Old 02-25-2018, 06:13 PM
  #10  
Alex Sol
User
Thread Starter
 
Alex Sol's Avatar
 
Join Date: Sep 2006
Location: Toronto
Posts: 620
Default

@djantlive

transmission oil - fresh less than 3,000 kms - synthetic blend
tire pressure - slightly high if anything but good point
fuel cleaner - i've removed all the fuel in the tank not too long ago.. say 4,000 kms ago. i make a 3 wire splice and plugged into the relay (that often dies) and the gas was all pumped out
i do have a fresh fuel pump also

@rocketrob - spark plugs - i had them all out and they were fresh at the time. i cleaned them lightly before installing and haven't checked em. perhaps on my valve adjustment which is coming out soon. Timing is set properly too... though i will have it checked again when doing the valve adjustment
Alex Sol is offline  
Old 02-25-2018, 06:20 PM
  #11  
Alex Sol
User
Thread Starter
 
Alex Sol's Avatar
 
Join Date: Sep 2006
Location: Toronto
Posts: 620
Default

@mikeH - i will check my brand new o2 sensor because i've heard that brand new sensors have been found to be defective... same goes with crank position reference sensor and anything that bosch makes !! haha

@rocketrob - i have brand new fiveomotorsport injectors and serviced my bosch units. no difference. i currently have the bosch units in so will swap em out for the five-0 set.

would the msd coils make a difference vs the bosch units? .. i have both and currently run the msd. there has been some debate about using these and i've found the msd work fine. avoid the silver bosch and keep the black ones if they meet the spec resistance

i want the 20 miles per gallon days back!!

we do have the winter gas here in Toronto - and i run the 91 octane but could get the 93... thoughts on possible improvement here?

meantime, power is good, smells a little rich even after fully warmed up. i will put on dyno in the next few weeks.

Is there any use to try a bosch hammer reset and adaptation? i do have ever so slight hunt at idle. between 850 rpm and 925 rpm...
Alex Sol is offline  
 


Thread Tools
Search this Thread
Quick Reply: Why is my gas mileage so crappy?


Contact Us - About Us - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: