Go Back  Rennlist - Porsche Discussion Forums > DIYs and "How To" Archive > 928
Reload this Page >

15 minute instrument pod removal update and instrument light bulbs for an OK price

Notices

15 minute instrument pod removal update and instrument light bulbs for an OK price

 
 
Old 10-06-2007, 02:32 AM
  #46  
Bill Ball
Under the Lift
Lifetime Rennlist
Member
 
Bill Ball's Avatar
 
Join Date: Mar 2002
Location: Buckeye, AZ
Posts: 18,467
Default

Schocki: I missed your reply. Maybe I wasn't clear. The oil pressure meter has been working perfectly since the reflow..
Bill Ball is offline  
Old 10-07-2007, 03:20 AM
  #47  
Schocki
Addict
Rennlist Member
Thread Starter
 
Schocki's Avatar
 
Join Date: Sep 2002
Location: Bucharest, Romania
Posts: 1,675
Default

Good to hear!
Finally, another electrical Gremlin bites the dust!

Good job and good to know that I was able to help you
Schocki is offline  
Old 10-26-2007, 05:32 PM
  #48  
carguyhere2
User
 
carguyhere2's Avatar
 
Join Date: Sep 2007
Posts: 89
Thumbs up

will be using these great instructions this weekend

Doing the ignition switch... Yay, fun!!

Thanks for the detailed post!!
carguyhere2 is offline  
Old 02-18-2008, 12:57 AM
  #49  
Rob Edwards
Archive Gatekeeper
Rennlist Member
 
Rob Edwards's Avatar
 
Join Date: Sep 2002
Location: Irvine, CA
Posts: 13,647
Default

Since I take the easiest of procedures and make them hard, I'd like to add one step to Shocki's most excellent instructions. After removing the knee bolster and the two metal brackets held by the 4 allen bolts, turns out there's a FIFTH allen bolt. It's on the left side, and runs up through the 2 rubber isolating donuts that sit in a U-shaped channel on the cluster and hold its left side. Like so:



I suspect that the 10-20 people who have done this since Schocki posted it figured this out as a matter of course, it took me a few minutes of headscratching as to why my pod was still stuck. The other tip is that the cluster needs to be moved to the left to get it off the right side mount, then you remove it from behind the pod by moving it back to the right, towards the midline of the car.

Now I just need to find out why two of my previously working odometer bulbs (that I didn't replace, ay yi yi) blew up after re-installation......

Roger- how's that comprehensive lamp replacement kit coming?
Rob Edwards is offline  
Old 04-12-2009, 09:35 AM
  #50  
Schocki
Addict
Rennlist Member
Thread Starter
 
Schocki's Avatar
 
Join Date: Sep 2002
Location: Bucharest, Romania
Posts: 1,675
Default

It was brought to my attention that the pictures of this post were missing. Updated and ready to go again! Sorry for any inconvenience.
Schocki is offline  
Old 04-12-2009, 11:14 AM
  #51  
mirousse
User
 
mirousse's Avatar
 
Join Date: Apr 2008
Location: Boisbriand, Québec, Canada
Posts: 248
Default

I haven't read all posts for this thread and somebody may have answered this already. Anyway, I replaced all my pod lights for less than 20$. I found the osram/sylvania mini bulbs at Allied Electronics. I can't recall the parts number but I can do a search if any of you is interested.

Michel
928 S4 89 Row
mirousse is offline  
Old 04-12-2009, 11:21 AM
  #52  
Schocki
Addict
Rennlist Member
Thread Starter
 
Schocki's Avatar
 
Join Date: Sep 2002
Location: Bucharest, Romania
Posts: 1,675
Default

Post the part #'s.
That would be helpful for all owners in the US
Schocki is offline  
Old 04-12-2009, 08:01 PM
  #53  
mirousse
User
 
mirousse's Avatar
 
Join Date: Apr 2008
Location: Boisbriand, Québec, Canada
Posts: 248
Default

All the bulbs I have replaced were Osram/Sylvania mini incandescent lamps T-1 1/2. The lamp model # is 2352MFX6. They're 0.49$ each!

Here's the Allied Electronics reference :

http://www.alliedelec.com/Search/Pro...320%2f2352MFX6

Here's the Osram/Sylvania mini lamp reference:

http://www.sylvania.com/ConsumerProd...ting/ECatalog/

Attachment 351596

Attachment 351597

Michel.
mirousse is offline  
Old 04-12-2009, 08:54 PM
  #54  
Bill Ball
Under the Lift
Lifetime Rennlist
Member
 
Bill Ball's Avatar
 
Join Date: Mar 2002
Location: Buckeye, AZ
Posts: 18,467
Default

Michel:

Did you replace ALL the yellow blue and green based bulbs with these or which color in Schocki's picture? [Thanks for restoring the pics, Schocki!]



Originally Posted by mirousse View Post
All the bulbs I have replaced were Osram/Sylvania mini incandescent lamps T-1 1/2. The lamp model # is 2352MFX6. They're 0.49$ each!

Here's the Allied Electronics reference :

http://www.alliedelec.com/Search/Pro...320%2f2352MFX6

Here's the Osram/Sylvania mini lamp reference:

http://www.sylvania.com/ConsumerProd...ting/ECatalog/

Michel.
Bill Ball is offline  
Old 04-12-2009, 09:39 PM
  #55  
mirousse
User
 
mirousse's Avatar
 
Join Date: Apr 2008
Location: Boisbriand, Québec, Canada
Posts: 248
Default

If I recall correclty:

-The 4 cluster illumination bulbs pull out from their socket and can be found at a car part store;
-The blue sockets are lower intensity bulbs (1.2 W I think). I managed to trade the inoperative blue bulbs with other blue bulbs on the board that were intented to be used on devices not installed on my car (ex: airbags). I'm pretty sure you can find them in the Osram catalog (see link). The 2352MFX6 model certainly fits in replacement for the blue ones. They are 2.0 W. They will be brighter and hotter too. I can't tell if it can harm the board or not.
-The 2352MFX6 bulbs were used to replace all yellow and light green socket. Four of them have red bulbs. Since the red bulbs were not available, just pull the rubber jacket off the old bulbs and stuff them on the new clear bulbs.

When replacing the bulbs, screw and unscrew them a couple of times to make sure the contact is made correclty. Otherwise you may end up rebuilding the pod and have a few new bulbs not lighting up because of bad contact with the board.

Hope this helps.

Michel.
mirousse is offline  
Old 04-12-2009, 09:56 PM
  #56  
mirousse
User
 
mirousse's Avatar
 
Join Date: Apr 2008
Location: Boisbriand, Québec, Canada
Posts: 248
Default

I just made a search in the Osram catalog. The blue socket bulbs appear to be a 2473MFX6 model. I'm not sure if they are easily available.

Michel.
mirousse is offline  
Old 04-12-2009, 10:03 PM
  #57  
Bill Ball
Under the Lift
Lifetime Rennlist
Member
 
Bill Ball's Avatar
 
Join Date: Mar 2002
Location: Buckeye, AZ
Posts: 18,467
Default

Michel - Thanks for the clarification.
Bill Ball is offline  
Old 04-12-2009, 10:31 PM
  #58  
Bill Ball
Under the Lift
Lifetime Rennlist
Member
 
Bill Ball's Avatar
 
Join Date: Mar 2002
Location: Buckeye, AZ
Posts: 18,467
Default

Michel:

Would this be the replacement for the blue based (1.2W) bulbs?
2351MFX6
http://www.alliedelec.com/Search/Pro...754%2F2351MFX6

According to this site, it cross-references with 2473MFX6 you suggest.
http://www.donsbulbs.com/cgi-bin/r/b...%7Cbx8.4d.html
Bill Ball is offline  
Old 04-12-2009, 10:43 PM
  #59  
Bill Ball
Under the Lift
Lifetime Rennlist
Member
 
Bill Ball's Avatar
 
Join Date: Mar 2002
Location: Buckeye, AZ
Posts: 18,467
Default

The 1.5W (yellow, green ) appear to be 2452MFX6, whereas the 2352MFX6 are 2W.
http://www.donsbulbs.com/cgi-bin/r/b...4d%7ctube.html

They do appear harder to find, but here's one possible source under $1.
http://www.aboveallmotorwerks.com/Pr...1391260_S.aspx
Bill Ball is offline  
Old 04-13-2009, 07:49 AM
  #60  
mirousse
User
 
mirousse's Avatar
 
Join Date: Apr 2008
Location: Boisbriand, Québec, Canada
Posts: 248
Default

I replaced all the higher watt rated bulbs (light green and yellow) with 2352MFX6 2W bulbs. It works perfectly. If I compare the A/T lever position (PRND32)(2W) with the warnings lights (1.2W), they don't appear that much brighter. (I'll provide a picture tonight).

I slept on this and took the car to work this morning during darkness. On second thought, I don't see any problem replacing all bulbs with those easy to find 2W. Since they don't light up all at the same time, all the time, I don't think the heat or the current draw would have an effect on the board itself. I would still use caution and do some test (ie watch for a fuse blow when all lights up at startup).

I'll take the bulb/socket measurments with a micrometer tonight and compare it with the Osram specs. I'll post the results for comparison.

Bye.

Michel.
mirousse is offline  

Thread Tools
Search this Thread
Quick Reply: 15 minute instrument pod removal update and instrument light bulbs for an OK price


Contact Us - About Us - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.