Notices
928 Forum
Sponsored by:
Sponsored by: 928 Specialists

Is this a normal ground point

 
Old 05-21-2011, 03:43 PM
  #1  
jacal128
User
Thread Starter
 
jacal128's Avatar
 
Join Date: Oct 2009
Location: Griffin, Georgia
Posts: 432
Default Is this a normal ground point

I found this wire behind the passenger side coil, the large end was through the bolt and the small end was just hanging. Is this a normal ground point or something someone has probably added ? Thanks, Jack Attachment 538116

Last edited by jacal128; 04-22-2012 at 10:23 PM.
jacal128 is offline  
Old 05-21-2011, 03:51 PM
  #2  
jacal128
User
Thread Starter
 
jacal128's Avatar
 
Join Date: Oct 2009
Location: Griffin, Georgia
Posts: 432
Post

Just checked the PET and it shows one, but not where the other end goes to.
jacal128 is offline  
Old 05-21-2011, 03:53 PM
  #3  
DR
Rennlist Sponsor
Rennlist
Site Sponsor

 
DR's Avatar
 
Join Date: Jun 2001
Location: Tampa, Florida
Posts: 4,295
Default

Normal, should have those ground cables on each side of the 32V engine coming from each coil bracket. Right side (cy 1-4) attaches to lifting ring (welded not on plate) just behind the rear/back of Cam gear backing plate.. Left side (cy 5-8) attached to threaded boss on rear/back side of cam gear backing plate. On 16V engine they bolt directly to cam tower housing.
__________________
David Roberts
2010 Jaguar XKR Coupe - 510HP Stock - Liquid Silver Metallic
928 Owners Club Co-Founder
Rennlist 928 Forum Main Sponsor
www.928gt.com

928 Specialists on Facebook - 928GTcom
Sharks in the Mountains on Facebook - 928SITM

DR is offline  
Old 05-21-2011, 04:32 PM
  #4  
BIMMERMIKE
User
 
BIMMERMIKE's Avatar
 
Join Date: Aug 2005
Location: Ontario, CANADA
Posts: 1,480
Default

There's plenty of discussion about good ground connections and the effect it has for a good running car, so I wonder how did your car run?
BIMMERMIKE is offline  
Old 05-21-2011, 04:41 PM
  #5  
jacal128
User
Thread Starter
 
jacal128's Avatar
 
Join Date: Oct 2009
Location: Griffin, Georgia
Posts: 432
Default

Ran fine, just doing a TB and WP and fixing what ever I stumble upon while doing it. I'll check the lift point and see about mounting it there. Thanks, Jack
jacal128 is offline  
Old 05-21-2011, 05:06 PM
  #6  
Ed Scherer
Addict
Rennlist Member
 
Ed Scherer's Avatar
 
Join Date: Jul 2001
Location: Shawnee, KS, USA
Posts: 7,058
Default

Ed Scherer is offline  
Old 05-21-2011, 05:31 PM
  #7  
jacal128
User
Thread Starter
 
jacal128's Avatar
 
Join Date: Oct 2009
Location: Griffin, Georgia
Posts: 432
Default

Got it, Thanks. Jack
jacal128 is offline  
Old 05-21-2011, 08:37 PM
  #8  
Landseer
Addict
Rennlist Member
 
Landseer's Avatar
 
Join Date: Sep 2007
Location: Frederick, Maryland
Posts: 11,263
Default

It was added for radio noise suppression in 85, 16 & 32V.
At some point a wiper motor ground was also added.

A number of us have pointed at the coil ground as inhibiting start.
Not sure its realistic, though.

Its not even shown on the wiring diagrams.
Landseer is offline  
 


Thread Tools
Search this Thread

Contact Us - About Us - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: